Read Crank No Start threads without success

E28 technical advice asked and given! Troubleshooting, modifications and more.
Post Reply
matreyia
Posts: 17
Joined: Dec 22, 2021 1:05 AM
Location: Houston

Read Crank No Start threads without success

Post by matreyia »

Hello Everyone, I am new here. Was mostly on e92 forums for my 335i but got a 1988 e28 528e recently and got myself in a bit of a pickle.
I am almost done with all mechanical maintenance and so far have done the following:
1. Transmission input/output seals, giubo, center bearing, filter and fluid change, differential fluid
2. pan gasket, valve adjustment, timing belt, all accessory belts, waterpump and thermostat, all hoses
3. new injectors, new ignition coil, new spark wires, new distributor cap and rotor,
4. removed some interior trim to release the transmission and have not put all trim back, radio is still out but shifter is reinstalled with connections.
5. new crank pulse sensor
6. new battery

Here is what stumped me... car cranks but doesn't start. I checked grounding for engine mounts, and the passenger strap to the valve cover.
Fuel pressure is strong but no fuel going to the spark plugs. I checked after trying to start the car and all cylinders are dry as are the plugs.
These are my few left over suspicions, please advise if you have any more suggestions.

1. OBC immobilzer is preventing engine to run since the car was disconnected from battery and I don't have a code for it. Which means I need to bypass somehow the immobilizer (any pointers appreciated).
2. I am missing a ground for the fuel injector harness somewhere that I didn't see when reinstalling the engine bay.
3. Neutral safety switch issue?
4. I need to reconnect ALL connectors and re-assemble all trim and radio before the car will run?

Totally stumped. Double checked underside for any grounding wire misses and all is in order.
I been reading for days of so many threads and none have matched exactly my situation. So I decided to post here.
Thanks for your time and suggestions.

VT
Shawn D.
Beamter
Beamter
Posts: 21503
Joined: Feb 12, 2006 12:00 PM
Location: Alpharetta, GA
Contact:

Re: Read Crank No Start threads without success

Post by Shawn D. »

matreyia wrote: Apr 23, 2022 10:26 PM Hello Everyone, I am new here.
Welcome! Please read and heed the Forum and Tech FAQs, and also be sure to put your post in the correct subforum (I had to move yours from "Comments," which is not for vehicle technical discussion).
matreyia
Posts: 17
Joined: Dec 22, 2021 1:05 AM
Location: Houston

Re: Read Crank No Start threads without success

Post by matreyia »

Sorry about that Shawn. I am not used to this interface yet.
matreyia
Posts: 17
Joined: Dec 22, 2021 1:05 AM
Location: Houston

Re: Read Crank No Start threads without success

Post by matreyia »

Ok, after reviewing the wiring next to the ECU there is nothing out of order. Radio is installed and anti-theft code properly entered. Also the immobilizer system is not an issue since there were no codes saved in the system. I did a test and created a code and the system works fine. But still no start.

I am reading from some owners that there is a ground for the ECU harness that is supposed to be connected to the intake manifold... I looked for that ground and did not find anything at all... can anyone point me in the right direction? where on the harness would be ecu ground be located? Because THAT would definitely be the issue for no start in my case.
Mike W.
Posts: 25676
Joined: Feb 12, 2006 12:00 PM
Location: California Whine Country

Re: Read Crank No Start threads without success

Post by Mike W. »

Welcome to the group!

I don't recall offhand how to bypass the OBC lockout, but search a bit, it's been covered many times and isn't difficult to bypass. I don't know if you've been into it, but never discount the main relay, it's unique and often mistaken for other 5 pin relays which will not work. It's very specific.
matreyia
Posts: 17
Joined: Dec 22, 2021 1:05 AM
Location: Houston

Re: Read Crank No Start threads without success

Post by matreyia »

It appears that I don't need to deal with the obc immobilizer. I got excited thinking it was one of the ground bundles on the intake manifold at the front and rear over the starter...but alas, my 1988 528e does not have those ground bundles so they are out of the equation...I'm back and first base again...damn...
Joey28
Posts: 74
Joined: Nov 30, 2020 5:32 AM
Location: Effort, PA USA
Contact:

Re: Read Crank No Start threads without success

Post by Joey28 »

I got my 533i relatively cheap because it wouldn't start and the PO couldn't figure out why. One day it just decided not to start (but would crank). I couldn't figure it out at first either, but then I replaced the main ECU relay and *poof* it fired right up! Though I can't see how you have strong fuel pressure but no fuel making it to cylinders?
matreyia
Posts: 17
Joined: Dec 22, 2021 1:05 AM
Location: Houston

Re: Read Crank No Start threads without success

Post by matreyia »

One more question... if I get a used motronic 1.1 unit, does it need to be programmed to my car? I assume not since it's so old, unlike the e90 generation cars.
matreyia
Posts: 17
Joined: Dec 22, 2021 1:05 AM
Location: Houston

Re: Read Crank No Start threads without success

Post by matreyia »

UPDATE: tested spark - good
tested injector power - all good
tested inflow fuel supply - good
tested outflow fuel return line - dry as a bone

Conclusion: Fuel Pressure Regulator is dead. No fuel was entering the rail at all.

Ordered new Bosch unit. Will update in a few days after install.

I hope someone in the future can use this episode to solve any similar issue.
Galahad
Posts: 188
Joined: Sep 06, 2016 9:08 PM
Location: Beverly/Worcester, MA
Contact:

Re: Read Crank No Start threads without success

Post by Galahad »

matreyia wrote: Apr 24, 2022 9:59 AM One more question... if I get a used motronic 1.1 unit, does it need to be programmed to my car? I assume not since it's so old, unlike the e90 generation cars.
Nope, they're interchangeable as long as you get the same model unit. If you have an 88 528e it's likely to have m1.3 not m1.1
cdryden
Posts: 2
Joined: Apr 01, 2022 2:51 AM
Location: OREGON

e28 blade fuse box kit - CED

Post by cdryden »

Hello, I would like some information about your e28 blade fuse box kit. Are these still available? If so, how long does it take to ship to Oregon?

Earl Dryden
cdryden@pdx.edu
matreyia
Posts: 17
Joined: Dec 22, 2021 1:05 AM
Location: Houston

Re: Read Crank No Start threads without success

Post by matreyia »

Thanks Galahad. Good to know.
I am excited to get this thing back together sans all the jerry rigged spliced wires from the cabin to the hood for the horn and auxilliary fan operation...it looked like a bird nest before I ripped out all the rigged wires.

I got a new steering wheel and replaced the carbon ring to fix the horn and tomorrow will replace the auxiliary fan resistor as well to fix the fan issue. I suppose I can't blame the previous owner for rigging things since he had no access to forums or youtube back in the day over a decade ago.
Mike W.
Posts: 25676
Joined: Feb 12, 2006 12:00 PM
Location: California Whine Country

Re: Read Crank No Start threads without success

Post by Mike W. »

matreyia wrote: Apr 26, 2022 5:38 PM ... I suppose I can't blame the previous owner for rigging things since he had no access to forums or youtube back in the day over a decade ago.
Yeah you can. I started with BMWs with a Bav in the early 80s, there were manuals even then, with wiring diagrams, and I may not have always done things the same as the factory, parts were more of an issue then, but tried to do it to a factory level. I may not have always succeeded, but usually.
Post Reply