Check out my thermostat!

Specific conversations and info for the BMW E28 M5 and M535i.
48230M5
Posts: 320
Joined: Mar 31, 2010 11:48 PM
Location: Metro Detroit

Check out my thermostat!

Post by 48230M5 »

Image

This is what my thermostat looked like when I opened up the housing. Anyone seen this before? The car would never warm up, I thought it may not have even had a thermostat in it. When I finally had a chance to open it up to replace it, this is what I found.

Sorry for the crappy cell phone pic, but you get the idea...
Karl Grau
Posts: 9630
Joined: Mar 10, 2006 8:34 PM
Location: On the Beach

Post by Karl Grau »

I had one not quite as bad. It caused the same problem though.

Image
Philo
Posts: 2025
Joined: Feb 12, 2006 1:00 PM
Location: Long Beach, CA

Post by Philo »

I had one like that once.., didn't take a picture of it though.., :laugh: but seem to take pictures of every dam other part on my car. Now you're gonna have great heat.. unless your temp valve is toast.
1st 5er
Posts: 20710
Joined: Jun 13, 2008 12:15 AM
Location: Cypress
Contact:

Post by 1st 5er »

No, but the exact opposite on several occasions.
Blue Shadow
Posts: 9291
Joined: Feb 12, 2006 1:00 PM
Location: SE PA

Re: Check out my thermostat!

Post by Blue Shadow »

48230M5 wrote:
Sorry for the crappy cell phone pic, but you get the idea...
The piece is busted in two, cell phone pics are fine for something like that. Not like we are trying to see what kind of connector that is deep in the dash.
tn535i
Posts: 5356
Joined: Jul 14, 2006 1:30 PM
Location: Middle Tennessee

Post by tn535i »

Mine was about like Charles Gray's.
demetk
Posts: 8212
Joined: Aug 09, 2007 8:58 AM
Location: CT, USA

Post by demetk »

Mine too. I was so impressed by the destruction I had to snap a pic.

Image
Last edited by demetk on Dec 08, 2014 11:36 AM, edited 1 time in total.
M5BB
Posts: 1500
Joined: Jun 13, 2007 10:13 AM
Location: Peachtree Corners, Georgia

Post by M5BB »

I had one that looked like Charles example.

FYI- a couple years back after my rebuild I had a leak at the thermostat housing so ordered new o-ring and thermostat from Pelican Parts.
I got the stat and started to replace it and when i pulled the existing stat out the new one was not the same.
I looked for pictures and could see something was not right.
I contacted Pelican and of course were confident it was correct and they had not had any returns.
The stat they sent would fit in the housing but would be backwards.
I ordered one from Bav Auto (in stock) and it was the correct one.

I talked to Pelican again and told them what was happening.
I took some photos showing the difference and sent them to the owner and he in turn sent them to his supplier and a week later he called me and said the supplier discovered that the stat was miss packaged and was actually a 535 stat.
The amazing thing was he had sold 5-6 stats the last year and none came back. Someone is running around with an upside down 535 stat in their M5. :roll:
MicahO
Posts: 2481
Joined: Jan 07, 2010 8:50 AM
Location: Warwick, NY

Post by MicahO »

M5BB wrote: ....I got the stat and started to replace it and when i pulled the existing stat out the new one was not the same......
I had the same thing happen last March/April, though I had bought the Stat from Zygmunt. It was clearly wrong when I went to swap out the bad one in the car. It would fit reversed, but that just wasn't right.

I forget who I re-ordered the correct item from, I think it was BavAuto? I never bothered with a return/refund, just put the extra stat in my box o'extracrapImayormaynotuse.....
tn535i
Posts: 5356
Joined: Jul 14, 2006 1:30 PM
Location: Middle Tennessee

Post by tn535i »

I had intended to replace mine almost 3 years ago and even ordered a new one back when someone we won't mention was still in business, actually just before the whole relationship went sour. I got all the hoses and such from him Ok and everything was fine but the T-stat was wrong and I guessed it was a 535 one. I was not going to put it in backwards or anything like that so I set it aside in case I ever needed one for the other car and just re-used the t-stat from the M6 thinking it was working OK anyway. It failed just a month or two ago but I think it was an original 20+ year old one. So maybe that wrong t-stat I've still got in the spare parts bin was an honest mistake all along.

can I use that "extracrapImayormaynotuse" line to label my cabinet of stuff
ldsbeaker
Posts: 6127
Joined: Mar 25, 2007 10:14 PM
Location: Slicktop City, AZ
Contact:

Post by ldsbeaker »

tn535i wrote:can I use that "extracrapImayormaynotuse" line to label my cabinet of stuff
That sounds dangerous. I would do it as well, except if my wife saw that as a label, she would grab the garbage can.
After I put the garbage can back, I ask her if she's lost. This isn't the kitchen. Where's my sammich?





























































kidding. :rofl:
M5BB
Posts: 1500
Joined: Jun 13, 2007 10:13 AM
Location: Peachtree Corners, Georgia

Post by M5BB »

MicahO wrote:
M5BB wrote: ....I got the stat and started to replace it and when i pulled the existing stat out the new one was not the same......
I had the same thing happen last March/April, though I had bought the Stat from Zygmunt. It was clearly wrong when I went to swap out the bad one in the car. It would fit reversed, but that just wasn't right.

I forget who I re-ordered the correct item from, I think it was BavAuto? I never bothered with a return/refund, just put the extra stat in my box o'extracrapImayormaynotuse.....
Sounds like the same vendor. I can't seem to find the letter or email with the brand name.
Here's a photo I sent showing the M5 stat on the right.
Image

It's funny all these years later to discover that others have had the same problem with multiple vendors.
demetk
Posts: 8212
Joined: Aug 09, 2007 8:58 AM
Location: CT, USA

Post by demetk »

M5BB wrote:
MicahO wrote:
M5BB wrote: ....I got the stat and started to replace it and when i pulled the existing stat out the new one was not the same......
I had the same thing happen last March/April, though I had bought the Stat from Zygmunt. It was clearly wrong when I went to swap out the bad one in the car. It would fit reversed, but that just wasn't right.

I forget who I re-ordered the correct item from, I think it was BavAuto? I never bothered with a return/refund, just put the extra stat in my box o'extracrapImayormaynotuse.....
Sounds like the same vendor. I can't seem to find the letter or email with the brand name.
Here's a photo I sent showing the M5 stat on the right.
Image

It's funny all these years later to discover that others have had the same problem with multiple vendors.
Those t-stats are not interchangeable.
MicahO
Posts: 2481
Joined: Jan 07, 2010 8:50 AM
Location: Warwick, NY

Post by MicahO »

M5BB wrote:Here's a photo I sent showing the M5 stat on the right.
......
It's funny all these years later to discover that others have had the same problem with multiple vendors.
Mine looked the same; I'll look at the box this weekend and check the branding and part number labeling. When it happened I didn't bother checking much, didn't even look at the part number sticker. I just thought "Crap, they sent me a 535 Stat." Of course, that was *after* I had popped the old one off and drained the system. So I put it back together with the bad stat for another week or two. Then when I finally got the right stat I put it in and it didn't seal, :evil: so I had to do it a third time. I got good at swapping tstats! Practice makes perfect! :laugh:

I had other orders cooking at the time for other sensors and tune up parts (this was right after I got the car and was troubleshooting what turned out to be a bad TPS), so I just added a stat to one of those.
demetk wrote:Those t-stats are not interchangeable.
No - definitely not interchangable - but they fit, even seal, when put in backwards. Scary, but there are probably people out there running them.

Quick edit - here's a picture of the wrong tstat I was sent (on the left). It's a Behr and the box is labelled with the right (wrong) PN. The old tstat that I never threw out is on the right with the box from the correct Wahler replacement from BavAuto.

Image
bojangles
Posts: 1565
Joined: Feb 12, 2006 1:00 PM
Location: London, Ontario

Post by bojangles »

can someone summarise what and where to get the correct thermostat. I had mine apart twice 2 summers ago, never got the right one, and it is still running with the original one.

I would like to order the right one and try again this summer.
Karl Grau
Posts: 9630
Joined: Mar 10, 2006 8:34 PM
Location: On the Beach

Post by Karl Grau »

I bought my S38 stat from Pelican Parts on 3/29/09 for $24.75.
I think it was available elsewhere but I needed it fast.

And just to avoid any confusion, the broken thermostat pic I posted is from an M20.
M5BB
Posts: 1500
Joined: Jun 13, 2007 10:13 AM
Location: Peachtree Corners, Georgia

Post by M5BB »

I would think by now that Pelican has gotten the correct
stats.
After seeing Micah's photo I remembered the other brand was Wahler.
My problem with the miss packaged stat was approx the fall of 08.
MicahO
Posts: 2481
Joined: Jan 07, 2010 8:50 AM
Location: Warwick, NY

Post by MicahO »

M5BB wrote:I would think by now that Pelican has gotten the correct stats.
I'd agree with that. My Wahler was from BavAuto last spring. The wrong Behr was also last spring from Zygmunt. Bavauto seems the most reliable from this thread, though Pelican has always been great for customer service - call them and verify what they've got on hand, *before* they ship.
1st 5er
Posts: 20710
Joined: Jun 13, 2008 12:15 AM
Location: Cypress
Contact:

Post by 1st 5er »

Anybody try BluntTech.com?
John in VA
Posts: 5022
Joined: Feb 12, 2006 1:00 PM
Location: Leesburg, VA

Post by John in VA »

1st 5er wrote:Anybody try BluntTech.com?
Steve's prices & service are exceptional - been buying from him for years. Hopefully he could find out the brand before you buy.
1st 5er
Posts: 20710
Joined: Jun 13, 2008 12:15 AM
Location: Cypress
Contact:

Post by 1st 5er »

John in VA wrote:
1st 5er wrote:Anybody try BluntTech.com?
Steve's prices & service are exceptional - been buying from him for years. Hopefully he could find out the brand before you buy.
I'm putting together a parts list now for him and this'll be on it,
as I plan to totally refresh the cooling system on the ///M5 prior to The V and RTT trip.

I've never gotten a wrong part from him. :D
His prices, service, and giving back to the community, I'll add and agree, are exceptional.
M5BB
Posts: 1500
Joined: Jun 13, 2007 10:13 AM
Location: Peachtree Corners, Georgia

Post by M5BB »

1st 5er wrote:
John in VA wrote:
1st 5er wrote: I've never gotten a wrong part from him.
Just a reminder. This was not the wrong part because they (Pelican) didn't check the numbers, it was wrong from the manufacturer because the wrong thermostat was put in the correct box.
BMW 635
Posts: 105
Joined: Jun 27, 2008 3:16 PM
Location: Dallas Texas

Numbers please !!!!!!

Post by BMW 635 »

What is the correct part number for M thermostat?
bkbimmer
Posts: 5856
Joined: Mar 02, 2007 3:33 AM
Location: Portland, Or.

Post by bkbimmer »

This is why I replace thermostats every year!
M5BB
Posts: 1500
Joined: Jun 13, 2007 10:13 AM
Location: Peachtree Corners, Georgia

Post by M5BB »

Post Reply