Timing on m20b20 problems

E28 technical advice asked and given! Troubleshooting, modifications and more.
Post Reply
Arnelvaljevcic
Posts: 2
Joined: Mar 26, 2021 2:05 PM
Location: Denmark

Timing on m20b20 problems

Post by Arnelvaljevcic »

Hello.
My bmw e28 from 83 with the engine code m20b20 runs poorly at idle. when it is cold it runs high at idle for a few minutes until I give it a gas shock and it then stabilizes. Then it sounds and runs ok. But when at operating temperature, it starts and fluctuates up and down between 700 and 1000 rpm.
I have replaced sparkplug cabel , spark plugs, rotor, power distributor cover. Had timing belt off twice to be sure the marks are on spot the crank and cam, and the mark on the power distributor is also directly in front with the rotor. It also squeals from the timing belt very weakly but the timing belt is not too tight because i had tried to tightened it completely. And then near so much.
It runned great before belt replacement.
Tried with timing gun. But can't really see that much feels like it's all over the place. I've tried adjusting with hearing. And thats where i am at this point
No leak on vakuum
Is there anything that i could possibly try.
Thanks in advance
Shawn D.
Beamter
Beamter
Posts: 21308
Joined: Feb 12, 2006 1:00 PM
Location: Alpharetta, GA
Contact:

Re: Timing on m20b20 problems

Post by Shawn D. »

Did you set the plug gap?

Most of us here are familiar with the US spec cars, which don't have adjustable distributors. Does this one have the distributor on the side of the block, with a timing mark on the harmonic balancer?
Arnelvaljevcic
Posts: 2
Joined: Mar 26, 2021 2:05 PM
Location: Denmark

Re: Timing on m20b20 problems

Post by Arnelvaljevcic »

No i have not set the plug gap.
And yes it i is with distrubitor on the side :?
Post Reply