Joy: fixing bouncing idle and poor throttle response in 1 hour

E28 technical advice asked and given! Troubleshooting, modifications and more.
Post Reply
knunger
Posts: 676
Joined: Feb 12, 2006 1:00 PM
Location: Tucson,AZ.

Joy: fixing bouncing idle and poor throttle response in 1 hour

Post by knunger »

So, I've been putting up with the poor throttle response for a while but when my car sat for a couple weeks and it wouldn't idle properly and I had to slam it into second and pop the clutch to keep going after stops...

It would still buck a bit upon takeoff but not as bad as when I came to a near stop with throttle closed then throttled again.

So I pulled the ICV (squirted both sides of the connector), put a cork in one of the outlets splashed brake cleaner into the other and shook the hell out of it. Then I pulled the cork from one side to the other and did the same thing. Blasted it with air then soaked the whole mechanism with spray silicone.

Pulled the accordion to the throttle body, sprayed carb cleaner in there and wiped it out (I had done this a few years ago so it wasn't very dirty. I did have to open the throttle plate a smidgeon to meet the Mye28.com specification of "one red c*nt hair open".

Buttoned her up and she runs better than in a couple years.

Moral of the story: when you drive the same car daily it is very easy to miss stuff until it becomes an issue.

I wish I had a e28 guru here in Tucson that could drive my car once a year to tell me Dude: to need to address this, this, this and this.

Oh well, I'll just have to stumble on...
tn535i
Posts: 5353
Joined: Jul 14, 2006 1:30 PM
Location: Middle Tennessee

Re: Joy: fixing bouncing idle and poor throttle response in 1 hour

Post by tn535i »

Glad that worked but... I would not advise silicone of any kind in these parts. That silicon spray may migrate through the engine and it's not meant to be there. If it makes it out the exhaust it can be harmful to the O2 sensor.

I don't think the ICV requires lubrication but if I wanted to I would use engine oil since oil mist makes it's way into the intake anyway and engine oil is formulated not to foul things like O2 and cc's.

You might fix the other issues if you do an adjustment of the t/b and TPS so it puts things into the best operating range. The one hair method does not work IMO because these engine are old and things change from factory. Simply unplug the TPS and see what the idle speed does on a warm no load engine then if low adjust to about 1000-1100 rpm. Then plug it back in and adjust the TPS if necessary for idle control to engage. Well wait... do you have a three wire or two wire ICV? Not sure from your sig line which you are talking about. And regarding that I most certainly have become an old fart by most standards :laugh:
Post Reply